CVE-2026-33327

Publication date 20 July 2026

Last updated 3 November 2026


Ubuntu priority

Cvss 3 Severity Score

7.8 · High

Score breakdown

Description

libvips is a fast image processing library with low memory needs. The `vipsload` operation in versions before and including 8.18.0 could incorrectly determine image dimensions leading to an integer overflow and a subsequent heap-based buffer overflow. This has been patched in version 8.18.1.

Status

Package Ubuntu Release Status
vips 26.10 stonking
Not affected
26.04 LTS resolute
Fixed in 8.18.0-1ubuntu0.1~esm2
24.04 LTS noble
Fixed in 8.15.1-1.1ubuntu0.1~esm2
22.04 LTS jammy
Fixed in 8.12.1-1ubuntu0.1~esm3
20.04 LTS focal
Fixed in 8.9.1-2ubuntu0.1~esm2
18.04 LTS bionic
Fixed in 8.4.5-1ubuntu0.1~esm2
16.04 LTS xenial
Fixed in 8.2.2-1ubuntu0.1~esm1

Get expanded security coverage with Ubuntu Pro

Reduce your average CVE exposure time from 98 days to 1 day with expanded CVE patching, ten-years security maintenance and optional support for the full stack of open-source applications. Free for personal use.

Get Ubuntu Pro 30-day free trial

Severity score breakdown

CVSS version:

Base score 7.0 · High

Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N

Base score 7.8 · High

Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H


Access our resources on patching vulnerabilities