CVE-2025-59933
Publication date 29 September 2025
Last updated 3 November 2026
Ubuntu priority
Cvss 3 Severity Score
Description
libvips is a demand-driven, horizontally threaded image processing library. For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation is affected by a buffer read overflow when parsing the header of a crafted PDF with a page that defines a width but not a height. Those using libvips compiled without support for PDF input are unaffected as well as thosewith support for PDF input via PDFium. This issue is fixed in version 8.17.2. A workaround for those affected is to block the VipsForeignLoadPdf operation via vips_operation_block_set, which is available in most language bindings, or to set VIPS_BLOCK_UNTRUSTED environment variable at runtime, which will block all untrusted loaders including PDF input via poppler.
Status
| Package | Ubuntu Release | Status |
|---|---|---|
| vips | 26.10 stonking |
Not affected
|
| 26.04 LTS resolute |
Not affected
|
|
| 24.04 LTS noble |
Fixed in 8.15.1-1.1ubuntu0.1~esm2
|
|
| 22.04 LTS jammy |
Fixed in 8.12.1-1ubuntu0.1~esm3
|
|
| 20.04 LTS focal |
Fixed in 8.9.1-2ubuntu0.1~esm2
|
|
| 18.04 LTS bionic |
Fixed in 8.4.5-1ubuntu0.1~esm2
|
|
| 16.04 LTS xenial |
Fixed in 8.2.2-1ubuntu0.1~esm1
|
Get expanded security coverage with Ubuntu Pro
Reduce your average CVE exposure time from 98 days to 1 day with expanded CVE patching, ten-years security maintenance and optional support for the full stack of open-source applications. Free for personal use.
Get Ubuntu Pro 30-day free trialSeverity score breakdown
CVSS version:
Base score
5.1 · Medium
Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L
Base score
7.8 · High
Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
Related Ubuntu Security Notices (USN)
- USN-8994-1
- libvips vulnerabilities
- 3 November 2026